Overview

LS Interactive Guide

What web browsers can I use?
The most recent versions of Google Chrome, Firefox, and Safari are all fully supported by Canvas.
Do not use any version of Internet Explorer or any out-of-date web browser as they offer reduced
security and functionality.

Here is a list of the supported versions from Canvas:
https://community.canvaslms.com/docs/DOC-10720-67952720329

you can view the pdf version of LS Interactive Guide at:
La-Salle-Interactive-Guide.pdf